Cornish Hall End
Incident Report for County Broadband Ltd
Resolved
This incident has been resolved.
Posted Feb 10, 2020 - 22:40 UTC
Identified
Please note we’re aware of a network issue in your area. Our engineers are working quickly to fix this, and we’ll update you shortly. Thank you for your patience.
Posted Feb 10, 2020 - 12:20 UTC
This incident affected: Fibre Network (Cornish Hall End).